SYMPTOMS
The available space on a drive where a TBIE index is stored is too low to store additional indexes and space cannot be added to the particular drive.
CAUSE
The system was configured to store the indexes on a physical drive that has since become fully utilized and cannot be expanded.
RESOLUTION
In this situation, one option is to add another drive/share as a repository for additional TBIE indexes.
The index drives/locations are configured using the [IndexFolder] key parameter in the 'ZyLAB.Platform.WinService.exe.config.xml' file which can be found under '\Program Files\ZyLAB\Information Management Platform\Services\Bin\' folder.
New locations are added to the value and separated by ';' as in the example below:
<add key="IndexFolder" value="C:\ZyLAB Data\SearchEngine\Indexes;F:\SearchEngine\Indexes;H:\Data\Indexes" />
After completing the update, the 'ZyLAB Information Management Service x64' service (ZyLAB_IM_Service) must restarted for the change to be recognized by the system.
To move indexes, the Information Management Platform administrator has to:
- Stop the 'ZyLAB Information Management Service x64' service.
- Move indexe(s) to the new location(s).
- Start the 'ZyLAB Information Management Service x64' service.
NOTE: If a new index is being created then it must complete before being moved to another location.
APPLIES TO
6.6
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