SYMPTOMS
When you access an index in ZyFIND the following error is displayed:
- ZyFIND :The following error occurred while openeing index \ZyLAB Data\Indexes\m_.....
- TBIE: Get index settings error .. Unable to open the index. Error Code: 0x800413A2
When you access the same index in the WebClient the following error is displayed:
- ZyNET error: The search engine could not open the index you requested.
- <BR>\nFor indices residing on a network, this error is often caused because of insufficient rights for the <I>system account</I>.
In addition this error number is listed: 0x800413A2 - Error info: TBIE: Get index settings error.
The ZyLAB ediscovery processing execute performer process.exe log files contain the following error entries:
- ZyLAB.ZyIMAGE.Common.Indexes.SearchIndex - Cannot open index for searching at path:
- \\Servername\ZyData\Indexes\m_...\m_....IC1:System.Runtime.InteropServices.COMException (0x800413A2):
- TBIE: Get index settings error.at ZyLAB.ZyIMAGE.Interop.Hapi.IZyIndex.OpenForSearching()
Indexing service.log:
- Object reference not set to an instance of an object.
- Index 'xxxx' is unusable and require administrative attention. Please check error indication file for details
Hapi.log :
Error Hapi - Caught exception in GetIndexSettings erro during perfroming Opreation "Getsettings" Error during performing operations "Getsettings"
The index.err file contains the following information:
You can retrieve this file from your ZyLAB Data location.
Example: (.\ZyLAB Data\TBIE Indexes\m_..)
System.InvalidOperationException: Can't open index ---> System.InvalidOperationException
Can't open index ---> System.InvalidOperationException: Error object state corrupted. -> Can't create field "file_name" error: [database is locked]
at ZyLAB.TBIE.FieldStorage.RegisterField(FieldInfo fieldInfo)
at ZyLAB.Platform.Services.TBIE.Index.Open()
CAUSE
The index remains locked by the Index.err file.
RESOLUTION
- To unlock the index/database you must:
- Rename the following file: Index.err (\ZyLAB Data\TBIE Indexes\m_...) to ensure a file with this name is not present in that directory.
- Empty the folder \\ZyLAB Data\TBIE Indexes\m_...\SearchCache
- Restart the Information Management Service. This will restore access to your index.
APPLIES TO
6.3; 6.4; 6.4 Service Pack 1
Comments
0 comments
Article is closed for comments.