SYMPTOMS
ZyALERT service does not start. When attempting to launch the application, the application crashes. In the Microsoft Applications Event log you observer the following information about the application crash:
Event ID 1000:
Faulting application name: ZyAlertService.exe, version: 6.300.186.0, time stamp: 0x5141feda
Faulting module name: MSVCR100.dll, version: 10.0.40219.325, time stamp: 0x4df2be1e
Exception code: 0xc0000417
Fault offset: 0x0008af3e
Faulting process id: 0xddc
Faulting application start time: 0x01cf57b820eb5d2a
Faulting application path: C:\Program Files (x86)\ZyLAB\Information Management Platform\Bin\ZyAlertService.exe
Faulting module path: C:\Windows\system32\MSVCR100.dll
Report Id: 5f53f4fa-c3ab-11e3-870a-005056894e36
CAUSE
ZyALERT tables have become corrupted. This may occur when a forced system shutdown or failure was performed.
RESOLUTION
Restore ZyALERT tables from a back up:
- You need to revert the below files from your back up:
- \\ZyLAB Data\ZyALERT\Tables\alertId.dbf
- \\ZyLAB Data\ZyALERT\Tables\alerts.CDX
- \\ZyLAB Data\ZyALERT\Tables\alerts.dbf
- \\ZyLAB Data\ZyALERT\Tables\alerts.FPT
- Note that the location of the "ZyLAB Data" folder may be different on your system. Contact your ZyLAB Administrator to confirm where it is located or check the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ZyLAB\ZyProfileServer\Preferences\WorkingDirectory
- Start ZyALERT
Start ZyALERT without alerts (you will need to recreate the alerts previously defined):
- Create a backup of the files: alertId.dbf, alerts.CDX, alerts.dbf, alerts.FPT.
- Once you have created the back up, ensure to either rename or remove the original files.
- Launch ZyALERT application, this will create new versions of the above mentioned files.
- Configure new alerts.
- These files are created anew when launching ZyALERT application and you can now configure new alerts.
APPLIES TO
6.2; 6.2 Service Pack 1; 6.2 Service Pack 2; 6.3; 6.4
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