SYMPTOMS
Searching an index in the webclient or ZyFIND that should have results in it returns no hits for a particular user. When you login as a ZyLAB administrator you get hits on your search terms.
CAUSE
Results for one user and not for the other user can be noticed when Document security is enabled.
RESOLUTION
Document security allows you to control access to documents based on a field query.
To allow the user access to the document the user mask must be set appropiatly in Document Security.
- Open ZyINDEX
- Click on the "+" by Document (Repository) Security to expand it.
- Select the index you want to modify.
- Create a security group by clicking create (if you have a security group go to step 10).
- Enter a name for the group.
- Click "Create".
- Create a query for the group by clicking on the binocular icon.
- Click the "Create" button and enter a field query.
- Click OK.
- Set the user mask by clicking on the icon to "Set members and security masks for this group".
- Select the user (or group) you want to create a mask for.
- Click "Set Mask".
- Select the permissions the user needs.
- Click OK and then Close.
- Close ZyINDEX.
- Your index should now be configured for document security.
APPLIES TO
5.0 Service Pack 7; 6.0 Service Pack 1; 6.0 Service Pack 2; 6.0; 6.1; 6.1 Service Pack 1; 6.1 Service Pack 2; 6.2; 6.2 Service Pack 1; 6.2 Service Pack 2
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