SYMPTOMS
You are indexing with Adobe but you have no hit highlighting on PDF text documents when viewing the documents in the webclient.
CAUSE
This is caused by the fact that the ZyIMAGE.api file is not installed or you did not yet enable "Enable search highlights from external highlight server." in Adobe. ZyLAB integrated with a specific version of Adobe to display hit highlights on PDF documents. Adobe has made the decision to remove this functionality in later releases of its software.
RESOLUTION
Server side changes
The ZyIMAGE.api file is a plug-in for Adobe Acrobat and/or Adobe Reader (currently only version 6, 7, 8 and 9 are supported) which can be found in C:\Program Files (x86)\ZyLAB\ZyIMAGE\AddOn\Adobe PDF Plug-in. During installation of ZyLAB Information Management Platform the ZyIMAGE.api is automatically copied to the plug-in directory of Adobe Acrobat and/or Adobe Reader. In case Adobe Acrobat and/or Adobe Reader are installed after the ZyLAB Information Management Platform installation is done you must copy the ZyIMAGE.api file to the correct directory:
- Find the plug-in directory of Adobe Acrobat (and/or Adobe Reader) and copy the file in this directory (usually it is: "C:\Program Files\Adobe\Acrobat (version)\Acrobat\Plug_ins" or "C:\Program Files\Adobe\Acrobat (version)\Reader\Plug_ins").
- Open ZyINDEX.
- Create an Index.
- Open index settings.
- Click Advanced Options.
- Select index PDF files with Adobe Acrobat / Reader.
- (existing index needs to be erased after changing this Advanced index setting).
- Create webclient with default templates.
- Install Adobe reader 7 8 or 9.
Client side changes
- To enable hit highlighting with version 9.
- Open Adobe Reader.
- Click Edit|Preferences|Search.
- Check the box labelled "Enable search highlights from external highlight server".
- Un-check the "Use only certified plug-ins" box and click OK.
APPLIES TO
6.2 Service Pack 2
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