SYMPTOMS
When attempting to launch a webclient, the following error can occur: ‘ZyNET error: The search engine could not be started, or the index could not be found (error number 0x80004005)’.
CAUSE
The Windows error number ‘0x80004005’ usually indicates there is a problem accessing a specific location, either because it does not exist or because the user does not have sufficient permissions. In this case the ‘Temp’ location is not available.
RESOLUTION
- The ‘Temp’ folder location can usually be changed in the ‘Global Options’ menu of ZyINDEX. However, it can also be modified via the Registry on the server. There it exists in the following keys:
- ‘Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ZyLAB\Global Settings’ (on a 64-bit machine) or
- ‘Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ZyLAB\Global Settings’ (on a 32-bit machine).
- ‘Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ZyLAB\Modules\Hapi’ (on a 64-bit machine) or
- ‘Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ZyLAB\Modules\Hapi’ (on a 32-bit machine).
- It is recommended to use a temp location on a local drive on the server such as ‘C:\ZyLAB Data\Temp’
APPLIES TO
6.0 Service Pack 1; 6.0 Service Pack 2; 6.0; 6.1; 6.1 Service Pack 1; 6.1 Service Pack 2; 6.2; 6.2 Service Pack 1; 6.2 Service Pack 2
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