SYMPTOMS
When executing a lengthy query with FastCGI enabled in IIS, you receive the following error message “The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.” within the web server interface.
CAUSE
The FastCGI activity timeout is set to 300 seconds by default. If the query exceeds this 300 second timeout limit, the error message listed above will be displayed within the results window of the web server.
RESOLUTION
- On the computer running Internet Information Services, open IIS and navigate to the server name (EX: MACHINENAME (DOMAIN\USER) at the top level) in the “connections” panel on the left side of the IIS Manager interface.
- Next, click on the FastCGI Settings icon to open the FastCGI Settings panel.
- Then, click on the application ZyNET.exe in the list and navigate to “Activity Timeout” within the FastCGI Properties list.
- The default setting for the Activity Timeout is 300 seconds. Adjust this amount by increasing the time in seconds (recommended in increments of 100 seconds) until the error is no longer produced by testing the query in the web server interface.
APPLIES TO
6.1; 6.1 Service Pack 1; 6.1 Service Pack 2
Comments
0 comments
Article is closed for comments.