SYMPTOMS
Error message: Error 3091: Index is busy: most likely, another application has opened the index with the ZyINDEX option.
Or:
Error message: error 3091: Index is busy while opening an index.
CAUSE
This error message can have three causes:
- If you are using Windows 95/98 and you are not logged on to a PC as a user with an active user profile.
- The values for LockName, LockUser or LockPid in the settings.txt have invalid data in them. This might have happened during illegal shutdown of pc while running ZyINDEX.
- The logged on user does not have sufficient rights on the index folders.
RESOLUTION
- Always log on with usersname and password. This is important on a standalone pc where it might be possible to log on without a username or password. Win 95/98 and ME can operate with no log on but ZyIMAGE requires an active user profile. For Windows 98 press the Escape-key when starting the PC.
- Delete the contents of the lockname, lockuser, lockpid in the settings.txt of the index returning the 3091 error while opening. Set the values to:
[General]
LockName=
LockUser=
LockPid=0
If removing the entries does not solve the problem. Reboot the machine. Erase the index and rebuild again. - Ensure that the logged on user has full control on the index folders.
For example, if an installation sets the index root directory to the Zylab data directory of a network drive like 'F:' then the logged-on user must have full control of the 'F:\zylab data\indexes' folder.
APPLIES TO
6.0 Service Pack 1; 6.0 Service Pack 2; 6.0; 6.1; 6.1 Service Pack 1; 6.1 Service Pack 2; 6.2; 6.2 Service Pack 1; 6.2 Service Pack 2
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