SYMPTOMS
Documents are not successfully processed in the Legal Processing action item list (action failures and/or the ZyLAB Legal Review Standalone Service stops).
Processing gets stuck when a family root item is too large for the database to handle. An unexpected exception occurred: RetryOperation|System.InvalidOperationException
(See also the ZyLAB.EDiscovery.Review.Standalone.log - .\ProgramData\Zylab\EDiscovery\Logging)
The given value of type String from the data source cannot be converted to type nvarchar of the specified target column. ---> System.InvalidOperationException: String or binary data would be truncated.
CAUSE
This may happen if you process an email with a very long subject and attachments was processed. The email itself was not added to Legal Review because it had a very long subject that would not fit into the configured field. The Legal Review action fails with a message that a certain field is longer than the configured max Length. Since the Name (subject) is too large it is not fitting into the column and will retry infinitely.
RESOLUTION
In order to prevent document processing failures related to a field value operation restrictions:
- You have to add a line in the <appSettings> section of the EDiscovery\LegalReview\Review_Standalone - ZyLAB.EDiscovery.Review.Standalone.WinService.exe.config.
- Find the file ZyLAB.EDiscovery.Review.Standalone.WinService.exe.config and make a copy for backup purposes.
- Add the line: <add key="TruncateFieldValueBySize" value="True"/>
- In order to apply the setting make sure that the ZyLAB Legal Review Standalone Service is restarted.
APPLIES TO
3.5; 3.6; 3.7
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