SYMPTOMS
The following error is logged at WARNING level during User Synchronization phase:
WARN ZyLAB.EDiscovery.Exchange.Standalone.ExchangeSync.EwsFolderManager - Folder ArchiveRoot was not found in <EMAILADDRESS@DOMAIN.COM>
Microsoft.Exchange.WebServices.Data.ServiceResponseException: The specified folder could not be found in the store.
at Microsoft.Exchange.WebServices.Data.ServiceResponse.InternalThrowIfNecessary()
at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
at Microsoft.Exchange.WebServices.Data.Folder.Bind(ExchangeService service, WellKnownFolderName name)
at ZyLAB.EDiscovery.Exchange.Standalone.ExchangeSync.EwsFolderManager.GetFolderWithSubfolders(WellKnownFolderName wellKnownFolder, Boolean ignoreErrors)
CAUSE
Exchange Web Services (EWS) reports the specified mailbox does not have Archive folders.
RESOLUTION
Within Exchange, items are moved automatically from the primary user mailbox to the archive based on the retention settings. This warning message is expected should the reported mailbox not have an Archive.
In this case you can safely ignore it. In Exchange Management Shell, the following cmdlet lists all archive enabled users along with their archive mailbox settings. Get-Mailbox | where {$_.ArchiveDatabase -ne $null} | ft name, archivedatabase, archivename, archivequota, archivewarningquota -AutoSize |
APPLIES TO
3.7; 3.7 Service Pack 1
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