SYMPTOMS
TBIE indexing process appears to be stuck and you notice that during indexing an .err file is created in the: .\ZyLAB Data\TBIE Indexes\[indexname] folder.
CAUSE
This may occur if you have less than 80% of memory available for the ZyLAB Information Management Service/ZyLAB.Platform.WinService.exe process.
RESOLUTION
If the IndexSplitMemoryLimit is set to 80 it will use 80% of the physical available memory.
When less memory is available it will result in an error which will be written in an .err file.
The specific message differs per index build stage.
You can resolve this by changing the limit of the IndexSplitMemoryLimit:
- Open the C:\Program Files\ZyLAB\Information Management Platform\Services\Bin\ZyLAB.Platform.WinService.exe.config
- Change the limit of internal memory usage, available for the indexing engine: <add key="IndexSplitMemoryLimit" value="80" />
- If this value is set to 0, the block pool will automatically set the memory limit on the host system.
- Rename the following file: Index.err (\ZyLAB Data\TBIE Indexes\m_...) to ensure a duplicate file with this same name is not present in the directory.
This will allow you to proceed indexing.
APPLIES TO
3.7 SP1; 3.7 SP2; 3.8
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