SYMPTOMS
eDiscovery Bundle 3.9 installations will check the file version of hapi.dll to see if Information Management Platform patches were installed properly.
Using: [ProgramFilesFolder]ZyLAB\Information Management Platform\Bin\hapi.dll.
However, if Information Management Platform was installed to an alternate disk or location, the check fails and the eDiscovery Bundle 3.9 installation will give an error code 1603 and rollback.
Msi log: Action 12:57:49: Installing ZyPlatform6.5Updates. Installing ZyPlatform6.5Updates The installation of ZyPlatform6.5Updates has failed. Setup will now exit.
InstallShield 13:01:14: *** Prerequisites complete; return code 2 InstallShield 13:01:14: Destroyed Window {3B66BB69-007C-40BD-806A-7E408520AB69}
CustomAction ISInstallPrerequisites returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox) Action ended 13:01:14: ISInstallPrerequisites. Return value 3.
CAUSE
eDiscovery Bundle 3.9 installations will fail to install (error 1603) if Platform 6.5 was installed to an alternative location (related to EDRM-8622)
RESOLUTION
Before installing eDiscovery Bundle 3.9 (Legal Processing and Legal Review) manually install the platform patches which are located in the installation bundle: DISK1\ISSetupPrerequisites\ZyPlatform6.5Updates\ZyIMPlatform-6.5 Hotfix for3.9 General.exe
Then, For Legal Processing and Legal Review installations:
Open disk1\setup.ini and go to the bottom, section [ISSetupPrerequisites].
Remove these 2 lines:
PreReq1=ZyPlatform6.5Updates.prq
PreReqFeatures1=EDiscovery
Then run the setup.exe
APPLIES TO
3.7 Service Pack 2; 3.8
Comments
0 comments
Article is closed for comments.