SYMPTOMS
Legal Hold is not sending out reminders and the following error is found in the ZyLAB.EDiscovery.Hold logfile: "ERROR ZyLAB.EDiscovery.Hold.Server.EmailPersistanceManager - System.Exception: Principal with sid = S-x-x-x-xxxxxxxx-xxxxxxxxx-xxxxxxxxx-xxxxx was not found"
CAUSE
This error typically appears when you remove users from Active Directory prior to removing them from the Legal Hold.
RESOLUTION
You will need to delete the users from the Legal Hold database manually:
1) Record the ID from the Contact table in the ZyLABLegalHold database using their EmployeeID, where ####### is the actual EmployeeID, by running the following query:
SELECT *
FROM [ZyLABLegalHold].[dbo].[Contact]
where EmployeeID = '#######'
2) Where XXXX is the ID recorded in the first step, record the HoldID(s) assigned to the contact using the following query:
SELECT *
FROM [ZyLABLegalHold].[dbo].[HoldContact]
where ContactID = 'XXXX'
3) Confirm then delete the employee(s) from the HoldContact table with the following SQL statements, where XXXX is the ID recorded in the first step and YYYY is the HoldID recorded in step 2:
SELECT * FROM [ZyLABLegalHold].[dbo].[HoldContact] where ContactID = 'XXXX' and HoldID = 'YYYY'
DELETE FROM [ZyLABLegalHold].[dbo].[HoldContact] where ContactID = 'XXXX' and HoldID = 'YYYY'
APPLIES TO
3.7; 3.7 Service Pack 1; 3.7 Service Pack 2; 3.8; 3.9
Comments
0 comments
Article is closed for comments.