SYMPTOMS
A Legal Processing job has the status of "Waiting on Review Environment", all job actions are completed, and a longer time has passed than would be expected to add the jobs document volume to the Legal Review Index and complete the job.
CAUSE
Multiple causes may apply.
RESOLUTION
Legal Review Standalone service
- Restart the Legal Review standalone service.
Verify ZyTimer service
- Make sure that the ZyTimer service is running and entries for the Matter/index (Text and Media) in question are in the ZyTimer list. If this did not work and you notice processing actions codes other then 0 in the Legal Review TEMP table you can proceed with the following actions:
Legal Review TEMP table
[Ensure to validate with ZyLAB Customer Support whether you should proceed with the below actions.]
One way to check the status of the entries that are yet to be added to Legal Review is to review the LR TEMP table specific to the Matter.
In most cases, if entries exist, the ‘IsFamilyCompleted’ field should = ‘1’ and the ‘ProcessingActions’ field will be a mix of the following:
Processing Actions Code Description
- 0 Indexed (Ready for Legal Review)
- 1 Email threading is being created
- 2 Waiting for Document Indexing
- 4 Waiting for Media Indexing
- 6 Waiting for Media and Full Text Indexing
Open the ‘ZyLABLegalReview’ database in SQL Server Management Studio and navigate to the Matter specific TEMP table (M_####_TEMP) for the job. Perform the following query on the table:
SELECT IsFamilyCompleted,count(*) as #
,CASE
When IsFamilyCompleted=1
then 'Family completed'
When IsFamilyCompleted=0
then 'Waiting for Legal Processing to confirm'
END AS Description
FROM [ZyLABLegalReview].[dbo].[M_####_TEMP]
group by IsFamilyCompleted
SELECT [ProcessingActions],count(*) as #
,CASE
When [ProcessingActions]=0
then 'Email threading and Indexing is done'
When ([ProcessingActions]&2)<>0 or ([ProcessingActions]&4)<>0
then 'Waiting for indexing'
END AS Description
FROM [ZyLABLegalReview].[dbo].[M_####_TEMP]
group by [ProcessingActions]
If all entries have ‘FamilyIsCompleted’ set to ‘1’ and some have a status code of ‘2’ in the ‘ProcessingActions’ field, check if these documents are in the index using the following steps:
Perform the following query of the Matter specific TEMP table to identify the documents keeping the job from completing which are the entries where the ‘ProcessingActions’ code is other than ‘0’:
SELECT * FROM [ZyLABLegalReview].[dbo].[M_####_TEMP]
WHERE [ProcessingActions]<>0
Record the ‘IndexId’ from the results to use in a ZyFIND search as the ‘document_id’. Open ZyFIND, select the correct index, then run a document_id search like the following example for each of the entries in the results of the previous query: document_id={D31BDA1A-0709-4D15-9A77-37F862C66BEF}
If documents are in the index, the documents in the TEMP table can be pushed through by correcting the ProcessingActions code to recognize that the documents have been indexed.
Run the following SQL UPDATE statement in SQL Server Management Studio:
update [ZyLABLegalReview].[dbo].[M_####_TEMP]
set ProcessingActions=0
A restart of any services or application pools should not be required for the job to complete.
Verify IndexOffset
During the processing of a job there are 2 locations where a count of documents in an index are maintained. In the past, it has been observed that these numbers can become out of sync which could negatively affect a Legal Processing job. Documents are added to files in the ‘\ZyLAB Data\TBIE Indexes\m_##\BuildQueue’ folder, then transferred to Legal Review. If there are more files than the ‘build.queues’ file (usually 8KB in size) in the ‘\BuildQueue’ folder contains, then the index is still being built. As documents are added to the index, the <DocumentsInIndex> number in the ‘\ZyLAB Data\TBIE Indexes\m_##\index.cfg’ file is updated and checked against the number referenced in the ‘IndexOffset’ field for the Matter in the [ZyLABLegalReview].[dbo].[Matter] table. As long as the number referenced as the ‘IndexOffset’ is higher than the <DocumentsInIndex> number, the job continues as if more documents are to be added to the index and the status will not change to 'Completed'.
When the index build is complete, there will only be 1 file in the ‘\BuildQueue’ folder and the number referenced as <DocumentsInIndex> should match the number set in the ‘IndexOffset’.
If indexing has completed and the numbers do not match, then set ‘IndexOffset’ field in the Matter table to ‘0’, where ## is the LegalReview Matter ID, using the following query statement in SQL Studio Management Studio:
UPDATE [ZyLABLegalReview].[dbo].[Matter]
SET IndexOffset = 0
WHERE Id = ##
Restart the ‘ZyLAB Legal Review Standalone Service’.
The number will be reset to the actual number the next time the Index is built by ZyTimer.
The job will proceed and complete.
APPLIES TO
3.7; 3.7 Service Pack 1; 3.7 Service Pack 2; 3.8
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