SYMPTOMS
A red "Preview not available" message is displayed instead of the documents thumbnails when accessing the Web Client via HTTPS. The same works fine when using HTTP.
CAUSE
Webserverextensions is not available. This is due to SSL Settings in Microsoft Internet Information Services (IIS) set to Require the Client Certificate, and sslBinding not configured in '\Program Files (x86)\ZyLAB\Information Management Platform\Webserverextensions.webservice\Web.config'.
RESOLUTION
If you do not require that users have client certificates to run the Webserverextensions Web application, use the Accept option instead of the Require option of the "Client certificates" feature. You can change this setting on the SSL Settings page for the Web application in IIS Manager. See the following Microsoft Knowledge base article: http://support.microsoft.com/kb/942067.
Alternatively make sure the users have client certificates to run the Webserverextensions Web application and that it is configured with the proper binding configuration. You can set the Webserverextensions binding configuration in the '\Program Files (x86)\ZyLAB\Information Management Platform\Webserverextensions.webservice\Web.config' configuration file.
- Create a backup copy of the existing "C:\Program Files (x86)\ZyLAB\Information Management Platform\Webserverextensions.webservice\Web.config" configuration file.
- Open "C:\Program Files (x86)\ZyLAB\Information Management Platform\Webserverextensions.webservice\Web.config" in a text editor.
- Navigate to the configuration > system.serviceModel > services section.
- Comment-out the httpBinding configuration and uncomment the sslBinding configuration.
The following is an exmaple of how this configuration section should look like.
<services>
APPLIES TO
6.3; 6.4; 6.4 Service Pack 1
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