SYMPTOMS
After deleting one or more documents in a HAPI index with Document Security enabled, a Quick Build scheduled, automatic, or manual action does not remove the documents from the index. The files are deleted from the file system correctly but the index is not updated, therefore the documents still appear in the result list but are not accessible. This occurs when deleting documents via both ZyFIND and Web Client.
CAUSE
This is a known issue and due to the fact that the user building the index does not have enough Document Security privileges to see the documents that have been deleted.
RESOLUTION
This will be addressed in future Information Management Platform software releases. Meanwhile it is possible to work around this by either scheduling an Update Build action in ZyTIMER, or modifying Document Security to assign Full Mask permissions on All Documents for the user building the index.
Full Mask permissions on All Documents
- Open the index in ZyINDEX.
- Navigate to the Timer tab. Check that a ZyTIMER task for this index has been created with Frequency Automatic.
- Navigate to the Security > Document Security tab, and select the index.
- In the Manage groups for document security page, click on the icon next to the All Documents group.
- Select the Account that is used to launch ZyTIMER Service. Click on the Set Mask button.
- Tick Permission to assign Full Mask permissions to this user and press OK.
- Press Close and close ZyINDEX.
Note that there is a potential security risk with the ZyTIMER Service Account having Full Mask rights on all documents in the index. The Service Account's password usually doesn't change, and being used to launch Windows NT Services is more vulnerable to hacks and exploits.
Schedule an Update Build with ZyTIMER
- Open the index in ZyINDEX.
- Navigate to the Timer tab. Check that a ZyTIMER task for this index has been created with Frequency Automatic.
- Next to the Automatic task, create a new task from the File > New menu.
- For Index Directory, Select the same index.
- For Frequency, select Every 1 day for instance.
- In the Next Update section, select a time frame that is suitable for the Update build. i.e. outside working hours.
- In the Action section, tick only Update.
- Click on Add Now.
Note that documents deleted will disappear from the result list once the Update build is completed. The time it takes for an Update build to complete grows with the size of the index. As the index grows large, it may come to take a long time to complete as it actually checks the file system for the presence of each indexed file.
APPLIES TO
6.1; 6.1 SP1; 6.1 SP2; 6.2; 6.2 SP1; 6.2 SP2; 6.3; 6.4; 6.4 SP1
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