SYMPTOMS
You have setup Information Management Platform to lookup database values and store them in index fields. However the "No database connection string found" error occurs when clicking on the 'Lookup' button in the ZyFIELD phase of a ZySCAN job.
CAUSE
The connection string was not entered in the ZySCAN template for this workstation. Likely the ZySCAN template field definitions have been created manually rather than being imported from the ZyINDEX index.
RESOLUTION
Make sure that the ZySCAN template for this workstation and the destination index have the same field definitions.
Depending on your current workflow, you can do this by either connecting the ZySCAN template to the destination index directly (Step 2 of the New Template creation wizard, "Template Wizard - Internals"), or by importing the field definitions from the destination index manually.
To import the field definitions from the destination index manually:
(1) From ZySCAN click on the Template > New Template menu item.
(2) Depending on your setup, either Define new job template or Define new job template based on existing job template.
(3) Go through the New Template creation wizard choosing the options that suit you.
(4) On Step 5 of the New Template creation wizard, "Template Wizard - ZyFIELD", Click on the Field Definitions... button.
(5) In the Field definitions window click on the Import definitions... button.
(6) Select the FIELDS.TXT file from your destination index's directory. i.e. "C:\ZyLAB Data\Indexes\<INDEX_NAME>\FIELDS\FIELDS.TXT".
Should you require further assistance with the steps above, don't hesitate to contact ZyLAB Support by creating a case via Support Portal https://support.zylab.com.
APPLIES TO
6.0; 6.1; 6.1 SP1; 6.1 SP2; 6.2; 6.2 SP1; 6.2 SP2; 6.3; 6.4
Comments
0 comments
Article is closed for comments.