SYMPTOMS
When browsing and logging in to the Workflow page (http://SERVER_NAME/ZyWorkflow/ by default), you see a "You have no permissions to use the workflow" error.
CAUSE
The user credentials you are logging in with doesn't have enough permissions to access Workflow.
RESOLUTION
Depending on the security configuration set during deployment, you could be prompted for login or not when browsing to http://SERVER_NAME/ZyWorkflow/. Please check with your ZyINDEX Administrator what account you should be logging in with and whether you should login automatically.
If you are the ZyINDEX Administrator, please check that the right permissions are assigned to the user.
- Start ZyINDEX. On the left pane, select the Workflow icon.
- Expand the Workflow you created and select "Templates".
- In the Templates page, click on the template you want to modify.
- Check the "Management pool" section to confirm which users are assigned to the "Controllers", "Administration" and "Budget holders" WorkPools. If the user is not part of the right WorkPool or not listed at all, continue with the next steps.
- Expand the Workflow you created and select WorkPools.
- Click on the Workpool you need to modify.
- In the WorkPool details page, click on the small folder icon to add a new user.
- Select the user from the Security Users/Groups page and press OK.
- Click on Update. You should be back to the WorkPools page, where you can confirm that the new user has been added to the correct WorkPool.
For more information on how to manage security and WorkPools, please refer to the "Create Workpools" chapter at page 250 of the ZyINDEX manual.
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APPLIES TO
2.4
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