SYMPTOMS
After a field or full text search in ZyFIND or the Web Client, the fields are empty in the result list and the document can not be viewed. (no document found).
CAUSE
This is related to incorrect configuration.
RESOLUTION
Using a Database fields connection with Oracle you should always write the id NAME and PATH in Capitals
Change it in the databasefield.xml this: (\ZxpPlugins\Database fields folder)
<fielddefinition name="Name" type="3" size="200" dbsync="1" id="NAME" primarykey="1" indexed="default" />
<fielddefinition name="Path" type="3" size="240" dbsync="1" id="PATH" primarykey="1" indexed="default" />
The ado.xml should contain an additional parameter which allows fields to be not case sensitive.
<parameter id="CaseSensitivKeyFields">False</parameter>
APPLIES TO
6.3
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