SYMPTOMS
'Error opening template file' error message is experienced by a user while navigating in the Web Client after the page remains idle without being refreshed for a period of time. At the same time, other users are able to successfully use the WebClient without any issues.
CAUSE
ZyNET Session Server process removes expired web sessions after period of time configured for Webserver Session Timeout is reached.
RESOLUTION
Follow these steps to modify the time after which the web session will be removed from memory:
- Open ZyIndex then select the Security tab
- Expand the General menu and select Settings
- Set the Webserver Session Timeout setting
PS: Setting the WebServer Session Timeout to '1 day' can overload the ZyNetSession Server process after some time with inactive users sessions which could cause the process to hang in memory and keep users from accessing the WebClient. The only way to restore the service is to:
- open Task Manager and find ZyNetSession process
- right click on it and select End Task
- hit OK
PPS: By default Webserver Session Timeout parameter is set to '20 min'.
APPLIES TO
6.4 Service Pack 1
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