SYMPTOMS
A Production fails for some reason due to insufficient system resources or (random) server problems. If the production is large and was running for some time before failure, it may be possible to complete the failed Production actions and minimize the time taken to complete the Production.
CAUSE
Production failure could be caused by disk access issues due to unavailable disk-space, insufficient rights to create folders/image files, power outage or server reboots.
RESOLUTION
To retry failed documents after resolving the cause (like for instance adding sufficient system resources) and correct Load Files you can proceed using these steps:
- Stopped the Legal Production service after confirming that there were no productions running.
- Searched the \ProgramData\Zylab\LegalProduction\Productions.sqlite database for the name of the production in question and found the associated GUID (ID) for the job.
- Run a query statement using the Name of the production as recorded in the Productions.sqlite table:
update [Production] set [Status] = 3 where [Name] = 'Production Name'
- Using the ID retrieved from the Productions.sqlite database go to the \ProgramData\ZyLAB\LegalProduction\[ID] folder
- Open the Production.Sqlite database and run the following query:
update [ProductionDocument] set [Status] = 1 where Status = -1
- Start the Legal Production service.
APPLIES TO
3.6; 3.7 Service Pack 1; 3.7 Service Pack 2; 3.8
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