SYMPTOMS
You experience that ZyLAB.Ediscovery.Client has stopped working. Following error is listed in the ZYLAB.EDiscovery.DataService log:
ERROR ZyLAB.EDiscovery.DataService.DataService - System.Data.Services.DataServiceException: Checking license failed. See inner exception. ---> ZyLAB.ZyIMAGE.Common.ZyImageException: Caught exception checking server license ---> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.
at ZyLAB.ZyIMAGE.Interop.License.ZyLicensesClass.AcquireServerLicense(String serverCode, UInt32 version, Guid UserId, String UserName)
at ZyLAB.ZyIMAGE.Security.Licenses.LicenseServer.CheckServerLicense(String applicationCode, UInt32 version, Guid userID, String userName)
— End of inner exception stack trace —
at ZyLAB.ZyIMAGE.Security.Licenses.LicenseServer.CheckServerLicense(String applicationCode, UInt32 version, Guid userID, String userName)
at ZyLAB.EDiscovery.DataService.DataService.CheckLicense(String productCode, UInt32 productVersion, Guid userId, String userName)
— End of inner exception stack trace —
CAUSE
No license installed or the license system object is in a hung state.
RESOLUTION
If the system has been running without any issue and the license.lic is still accessible (and no permission changes were applied), you can end the licenseserver.exe*32.exe process using the task manager.
APPLIES TO
3.6; 3.7; 3.7 Service Pack 1; 3.7 Service Pack 2; 3.8
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