SYMPTOMS
The eDiscovery service assigns actions to be performed to the nodes where the eDiscovery processing service runs. In the case of the TIFF producer, depending on the number of cores your machine has, the configuration of the performer pool and the OCR license available, you may run into TIFF Producer actions timing out with message: Time Out. End of Process.
CAUSE
When the number of Execute Performers started exceeds the number of licensed OCR cores, some Execute Performers are waiting for the Global Professional OCR license to become available. If it does not become available within the configured time out time, the action will fail.
RESOLUTION
Each Execute Performer represents an action for the TIFF Producer, requiring an OCR license to be available. When the concurrency pool associated to TIFF Producer processor, by default "Tiff Pool", is higher than the number of available OCR licenses per core, TIFF Producer actions will be started but will be waiting to acquire a license. Once the Execute Performer is started, the configured time out time for the TIFF Producer process (default 10 minutes) is started. The more Execute Performers started simultanuously, the longer the wait time for an Execute Performer will be if it did not yet get a license upon completion of the previous Execute Performer. Eventually, if no license can be acquired within the configured time out time, the TIFF Producer action will fail with message: Time Out. End of Process.
As an example: you have a 1 core OCR license but you have configured the TIFF Pool concurrency to allow 2 x the cpucount of the processing node. This means that 4 Execute Performers are started but only the first will acquire the license. If this actions takes 5 minutes, it means that 5 minutes of processing time is left for the remaining 3 Execute Performers before timing out.
To validate whether you observe TIFF Producer time out messages due to license related issues, follow the below steps:
- Find, on the machine that runs the Global Professional OCR Engine, the file ProductProtection.log, located in \ProgramData\ABBYY\SDK\10\Licenses\
- Open the file and observe whether you see following message: "ERR_PROT_NO_FREE_LICENSE_VOUCHERS" at the time you have failed TIFF Producer actions due to a time out. This would typically appear every second as the license check is being done continuously.
- Next, check the TIFF Producer concurrency pool settings in PerformersSettings.xml (this would reside on the cluster node that executes the TIFF Producer processes) \Program Files (x86)\ZyLAB\EDiscovery\Processingservice\PerformersSettings.xml):
- In the section "Processors", check the Settings pools for the TIFF Producer.
- In the section "Pools", locate the pool that is assigned to the TIFF Producer and check whether the concurrency matches the number of OCR core licenses.
- If there is a mismatch, ensure to make a copy of the PerformerSettings.xml and make sure the concurrency equals the number of OCR core licenses.
Examples:
The recommended PerformerSettings.xml setting for a 1 core OCR license:
<Processors>
<Setting pools="Tiff Pool" available="true" use="true" name="Tiff Producer"/>
</Processors>
<Pools>
<Pool name="Tiff Pool" concurrency="1"/>
</Pools>
The recommended PerformerSettings.xml setting for a 4 core OCR license:
<Processors>
<Setting pools="Tiff Pool" available="true" use="true" name="Tiff Producer"/>
</Processors>
<Pools>
<Pool name="Tiff Pool" concurrency="4"/>
</Pools>
- After you have made the change, restart the ProcessingService on the processing node.
- You should validate whether your changes took affect by checking the ProductProtection.log again. You should no longer see "ERR_PROT_NO_FREE_LICENSE_VOUCHERS".
APPLIES TO
3.4
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