SYMPTOMS
In certain circumstances it is not possible to perform a batch assignment. For some reason the application might generate an error if the configured batch needs to be performed (Perform Assignments). The following error (similar) will be displayed in the Legal Review interface when you click on Diagnostics Information upon the "Oops - message":
...
2013-05-16 11:28:33.0415|ERROR|MACHINE NAME|Client|[High] EXCEPTION OCCURED:
[SFxFaultExceptionToString3]
Arguments: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail],Cannot insert the value NULL into column 'assignedto', table 'ZyLABLegalReview.dbo......'; column does not allow nulls. UPDATE fails.The statement has been terminated.,[SFxExceptionDetailFormat]
Arguments: Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.0.10411.00&File=System.ServiceModel.dll&Key=SFxExceptionDetailFormat
System.Data.SqlClient.SqlException: Cannot insert the value NULL into column 'assignedto', table 'ZyLABLegalReview.dbo......'; column does not allow nulls. UPDATE fails.
The statement has been terminated
CAUSE
This is caused by column properties not correctly set in the Legal Review template.
RESOLUTION
The original problem of not allowing nulls in the “assignedto” column of the M_00XX table is “fixed” by modifying LegalReview_v31.xml.
Change <IsRequired>True</IsRequired> to <IsRequired>false</IsRequired> as below:
<FieldInfoDto>
<Name>Assigned To</Name>
<DbType>NVarChar</DbType>
<Size>100</Size>
<IsIndexed>true</IsIndexed>
<IsRequired>false</IsRequired>
<IsFullTextSearchable>false</IsFullTextSearchable>
<IsUserVisible>true</IsUserVisible>
<DefaultValue></DefaultValue>
</FieldInfoDto>
You will need to create a new matter so that a new table with the correct column properties (nullable) are set.
APPLIES TO
3.1
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