SYMPTOMS
You are using Exchange Synchronization with Exchange Server 2010. The user mailbox has "audit" turned and you experience the mailbox collection to be very slow and the following error repeated many times for each mailbox: "Microsoft.Exchange.WebServices.Data.ServiceResponseException: Access is denied."
CAUSE
In 3.9 we are missing the exception for retries on ErrorAccessDenied.
RESOLUTION
Add following setting to the ESS config:
<add key="ErrorCodesToSkipWhenGettingFolderChanges" value="ErrorInvalidClientAccessTokenRequest;ErrorInvalidOperation;ErrorAccessDenied" />
APPLIES TO
3.9
Comments
0 comments
Article is closed for comments.