SYMPTOMS
Exchange synchronization is not accessing the configured mailboxes. The collection task does not retrieve any mailboxes, although the mailboxes can be retrieved from Powershell.
There is a NULL guid reference in the ZyLAB.EDiscovery.Exchange.Standalone.WinService.exe.log:
ZyLAB.EDiscovery.Exchange.Standalone.Utils.MailboxInfoHelper - Mailbox MailBox@client.domain.com (00000000-0000-0000-0000-000000000000) was not found in Exchange.
CAUSE
Mailbox references are case sensitive and should be added in lower case. Normally, when exchange synchronization works with journal items, the mailboxes are added by the service itself avoiding issues resulting from manual configuration.
RESOLUTION
Make sure the mailbox is added exactly as it was found from PowerShell (get-mailbox cmdlet) including lower and uppercase.
Example: (MailBox@client.domain.com).
The role assignments can be retrieved in a variety of ways including by assignment type, scope type, or name, and whether the assignment is enabled or disabled.
Additionally, a list of role assignments that provide access to a specified recipient, server, or database can be viewed.
In Powershell:
- Get-ManagementRoleAssignment -Enabled $True -Delegating $True
If journaling is not enabled, the mailbox(s) that to synchronize should be added manually, however in the Exchange Synchronization database, the mailbox should be added in lower case at all times.
After adding the mailbox in lowercase, mailbox access and synchronization will be restored.
APPLIES TO
3.8
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